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The SparkFun Inventor's Guide is your map for navigating 
the waters of beginning embedded electronics. This 
booklet contains all the information you will need to 
explore the 14 circuits of the SparkFun Inventor's Kit for 
Arduino. At the center of this manual is one core 
philosophy - that anyone can (and should) play around 
with electronics. When you're done with this guide, you'll 
have the know-how to start creating your own projects 
and experiments. Now enough talking - let's get inventing! 

sparkfun.com

Welcome to the SparkFun Inventor’s Guide
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Section 2: Getting Started with Circuits

Section 1:  Getting Started with Arduino

Arduino Uno

Breadboard

Circuit #1 - Your First Circuit: Blinking a LED

Circuit #3 - RGB LED

Circuit #4 - Multiple LEDs

Circuit #5 - Push Buttons
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Circuit #2 -  Potentiometer 



Arduino is an open-source physical computing platform 
designed to make experimenting with electronics more 
fun and intuitive. Arduino has its own unique, simplified 
programming language, a vast support network, and 
thousands of potential uses, making it the perfect platform 
for both beginner and advanced DIY enthusiasts. 

arduino.cc

The Arduino Revolution

What is an Arduino?

The friendly blue board in your hand (or on your 
desk) is the Arduino. In some ways you could 
think of Arduino as the child of traditional desktop 
and laptop computers. At its roots, the Arduino is 
essentially a small portable computer. It is capable 
of taking inputs (such as the push of a button or a 
reading from a light sensor) and interpreting that 
information to control various outputs (like a 
blinking LED light or an electric motor). 

That's where the term "physical computing" is 
born - an Arduino is capable of taking the world of 
electronics and relating it to the physical world in 
a real and tangible way. Trust us - this will all make 
more sense soon.

A Computer for the Physical World

// Arduino UNO SMD R3

The Arduino Uno is one of several development 
boards based on the ATmega328. We like it mainly 
because of its extensive support network and its 
versatility. It has 14 digital input/output pins (6 of 
which can be PWM outputs), 6 analog inputs, a 16 
MHz crystal oscillator, a USB connection, a power 
jack, an ICSP header, and a reset button. Don’t 
worry, you’ll learn about all these later.
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In order to get your Arduino up and running, you'll need to 
download some software first from www.arduino.cc (it's 
free!). This software, known as the Arduino IDE, will allow 
you to program the Arduino to do exactly what you want. 
It’s like a word processor for writing programs. With an 
internet-capable computer, open up your favorite browser 
and type in the following URL into the address bar:

Access the Internet

Download the Arduino IDE (Integrated Development Environment)

user

•••••••••

Windows

Mac OS X

Linux: 32 bit, 64 bit

N

W

S

E

NW

SW

SE

NE

arduino.cc/en/Main/Software < case sensitive >

Choose the appropriate Operating System installation package for your computer.

Download Click on the “ + ” sign next to your 
appropriate computer operating system. 

Windows

Mac OS X

source

Linux: 32 bit, 64 bit

1



// Connect your Arduino Uno to your Computer
Use the USB cable provided in the SIK kit to connect the Arduino 
to one of your computer’s USB inputs.

// Install Drivers

Depending on your computer’s operating system, you will need to follow specific 
instructions. Please consult the URLs below for specific instructions on how to 
install the drivers onto your Arduino Uno. 

* You will need to scroll to the section labeled “Install the drivers”.

2
3

Linux: 32 bit / 64 bit, Installation Process
Go to the web address below to access the instructions for 
installations on a Linux-based computer.

http://www.arduino.cc/playground/Learning/Linux

Macintosh OS X Installation Process
Macs do not require you to install drivers. Enter the following URL if 
you have questions. Otherwise proceed to next page.
 
http://arduino.cc/en/Guide/MacOSX

Windows Installation Process
Go to the web address below to access the instructions for 
installations on a Windows-based computer. 

http://arduino.cc/en/Guide/Windows
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Open the Arduino IDE software on your computer. Poke around and get to know 
the interface. We aren’t going to code right away, this is just an introduction. �e 
step is to set your IDE to identify your Arduino Uno.

// Open the Arduino IDE:



// The three most important commands for this guide are seen below:

GUI (Graphical User Interface)

Verify: Compiles and approves your code. It will catch errors in syntax (like missing semi-colons or parenthesis).  // See Diagram Below1

Upload: Sends your code to the Arduino board. When you click it, you should see the lights on your board blink rapidly. // See Diagram Below2

New: This buttons opens up a new code window tab.3

Open: This button will let you open up an existing sketch. // See Diagram Below4

Save: This saves the currently active sketch.5

Serial Monitor: This will open a window that displays any serial information your Arduino is transmitting. It is very useful for debugging.6

Code Area: This is the area where you compose the code for your sketch. 8

Message Area: This is where the IDE tells you if there were any errors in your code.9

Sketch Name: This shows the name of the sketch you are currently working on.7

Verify

Upload

Open



File Edit Sketch Tools Help

Auto Format
Archive Sketch
Fix Encoding & Reload
Serial Monitor

Arduino Uno
Arduino Duemilanove w/ ATmega328]
Arduino Diecimila or Duemilanove w/ ATmega168
Arduino Nano w/ ATmega328
Arduino Nano w/ ATmega168
Arduino Mega 2560 or Mega ADK
Arduino Mega (ATmega1280)
Arduino Mini 
Arduino Mini w/ATmega168
Arduino Ethernet
Arduino Fio
Arduino BT w/ ATmega328
Arduino BT w/ATmega168
LilyPad Arduino w/ ATmega328
LilyPad Arduino w/ ATmega168
Arduino Pro or Pro Mini (5V, 16 MHz) w/ATmega328
Arduino Pro or Pro Mini (5V, 16 MHz) w/ATmega168
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ATmega328
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ATmega168
Arduino NG or older w/ ATmega168
Arduino NG or older w/ ATmega8

Programmer
Burn Bootloader

Board
Serial Port

// Select your board: Arduino Uno

Select the serial device of the Arduino board from 
the Tools | Serial Port menu. This is likely to be 

com3 or higher (COM1 and COM2 are usually 
reserved for hardware serial ports). To find out, 
you can disconnect your Arduino board and 
re-open the menu; the entry that disappears 
should be the Arduino board. Reconnect the board 
and select that serial port.

Select the serial device of the Arduino board from 
the Tools > Serial Port menu. On the Mac, this 
should be something with /dev/tty.usbmodem 
(for the Uno or Mega 2560) or 
/dev/tty.usbserial (for older boards) in it.

http://www.arduino.cc/playground/Learning/Linux

Tools Help

Auto Format
Archive Sketch
Fix Encoding & Reload
Serial Monitor

com 1
com 12

Programmer
Burn Bootloader

Board
Serial Port

Tools Help

Auto Format
Archive Sketch
Fix Encoding & Reload
Serial Monitor

 /dev/tty.usbmodem262471
 /dev/cu.usbmodem262471
 /dev/tty.Bluetooth-Modem
 /dev/cu.Bluetooth-Modem
 /dev/tty.FireFly-7256-SPP
 /dev/cu.FireFly-7256-SPP
 /dev/tty.tiPhone-WirelessiAP-1
 /dev/cu.tiPhone-WirelessiAP-1
 /dev/tty.Bluetooth-PDA-Sync
 /dev/cu.Bluetooth-PDA-Sync

Programmer
Burn Bootloader

Board
Serial Port

//
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Type in the following URL to download the code:

Download Arduino Code (For use with the circuits in this guide)

sparkfun.com/sikcode

5

Unzip the file “SIK Guide Code”. 
It should be located in your 
browser’s “Downloads” folder. 
Right click the zipped folder and 
choose “unzip”. 

Copy the “SIK Guide Code” folder into Arduino’s 
folder named “examples”.

Copy the “SIK Guide Code” folder 
into Arduino’s folder  named 
“examples”.

Unzip the file “SIK Guide Code”. 
It should be loacted in your 
browser’s “Downloads” folder. 
Right click the zipped folder and 
choose “unzip”. 

Find “Arduino” in your applications 
folder. Right click(ctrl + click) on 
“Arduino”. Select “Show Package 
Contents”.

http://www.arduino.cc/playground/Learning/Linux
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Everywhere you look, you'll find circuits. The 
cell phone in your pocket, the computer that 
controls your car's emissions system, your 
video game console - all these things are chock 
full of circuits. In this guide, you'll experiment 
with some simple circuits and learn the gist of 
the world of embedded electronics.

The World Runs on Circuits:

Getting Started with Circuits

A circuit is basically an electronics loop with a starting 
point and an ending point - with any number of compo-
nents in between. Circuits can include resistors, diodes, 
inductors, sensors of all sizes and shapes, motors, and any 
other handful of hundreds of thousands of components. 

Circuits are usually divided into three categories - analog 
circuits, digital circuits, or mixed-signal circuits. In this 
guide, you will explore all three sets of circuits.

What is an Electrical Circuit?

// Simple and Complex Circuits

In this guide, you will be primarily exploring 
simple circuits - but that doesn't mean you 
can't do amazing things with simple tools! 
When you've finished the SIK, your 
knowledge of circuits will enable you to 
explore amazing projects and unleash the 
power of you imagination. 
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Inventory of Parts

* ACTUAL SIZE

(1N4148)
Diode

x2

x1

Piezo Element

Various Colors
Jumper Wire

x30

Push Button

x2x1

DC Motor

x1

DC Motor

x1

Potentiometer

(Light Emitting Diode)

x10 x10 x1

LED (5mm) +-

330Ω Resistor

x25 * ACTUAL SIZE

10KΩ Resistor

x25 * ACTUAL SIZE

(TMP36)

x1

Temp. Sensor

FRONT

BACK

(P2N2222AG)

x2

Transistor

P2
N2

22
2A

A1
8

FRONT

BACK

x1

Photo Resistor



Standard Solderless 
Breadboard
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Soft Potentiometer
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Servo
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Relay
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// Pins Diagram

Arduino Uno

Power In (Barrel Jack) - Can be used with either a 9V or 12V wall-wart or battery.1

Power In (USB Port) - Provides power and communicates with your board when plugged into your computer via USB.2

LED (RX: Receiving) - This shows when the Arduino is receiving data (such as when being programmed).3

LED (TX: Transmitting)  - This shows when your Arduino is transmitting data (such as when running a program). 4

LED (Pin 13: Troubleshooting)  - This LED is incorporated into your sketch to show if your program is running properly.5

Pins (ARef, Ground, Digital, Rx, Tx) - These various pins can be used for inputs, outputs, power, and ground. // See Diagram Below 6

LED (Indicates Arduino is ON) - This is a simple power indicator LED.7

Reset Button - This is a way to manually reset your Arduino, which makes your code restart.8

Pins (Analog In, Power In, Ground, Power Out, Reset)  - These various pins can be used for inputs, outputs, power, and ground.  // See Diagram Below10

ICSP Pins (Uploading Code without Bootloader)  - This is for "In-Circuit Serial Programming," used if you want to bypass the boot loader.9

Power Out

Reset

IOREF

RFU

Power Out

Ground

Ground

Power In

Analog

Analog

Analog

Analog

Analog

Analog

Ground

ARef

SDA

SCL

Digital

Digital

Digital

Digital

Digital

Digital

Digital

Digital

Digital

Digital

Digital

Digital

TX - Out

RX - In

10

6

= PWM/Analog out compatible (i.e.       )

The header pins are one of the most important parts for putting our 
example circuits together. Take a moment and locate the input/output 
ports of your Arduino Uno.
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Power:

Each + sign runs power anywhere in the 
vertical column.

Ground:

Each - sign runs to ground anywhere in the 
vertical column.

Horizontal Rows:

Each of these rows numbered 1-30 are 
comprised of five horizontal sockets. 
Components placed in the same row will be 
connected in a circuit when power is running.

Vertical Connection (+ Power and - Ground // See Diagram Below)1

Horizontal Connection (a-e & f-j // See Diagram Below)2

How’s it all connected?

View of the inside  
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Above the breadboard

CONNECTED!

LED

Making a Connection:

Inside the breadboard



CIRCUIT #1 - Your First Circuit

5V Current Your Arduino runs on �ve volts. �is is the power that will be supplied from your 
computer via USB and will be the driving force behind any components you use in your circuits. By 
plugging your Arduino board into your computer, you are supplying it with just the right voltage it 
needs to thrive! 5V can’t hurt you, so don’t be afraid to touch anything in your citcuit.

Peel sticker off back of 
Breadboard and stick into place.

How It Works:

ASSEMBLE WRITE UPLOAD

Make sure the text on the Arduino and 
Breadboard are facing up so you can read them.
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Connect the USB cable.



PA
RT

S: LED

1X

Wire

3X

330Ω
Resistor

1X This section lists the parts you 
will need to complete the circuit.

Circuit 2

LEDs (light-emitting diodes) are small, powerful lights 
that are used in many di�erent applications. To start o� 
the SIK, we will work on blinking an LED. �at's right 
- it's as simple as turning a light on and o�. It might 
not seem like much, but establishing this important 
baseline will give you a solid foundation as we work 
toward more complex experiments. 

Blinking a LED 1

Each Circuit begins with a brief description 
of the what you are putting together and 
the expected result.

This is a schematic of your circuit. 

Arduino 

LED
(Light Emitting Diode)

GND
(ground) (-)

Resistor
(Orange-Orange-Brown)

(330ohm)

This is an illustration of how the 
completed circuit should look. It is not 
necessary to use the black holder for the 
Arduino and Breadboard, but we 
recommend it for the first time inventor!

Components like Resistors need 
to have their legs bent into 90° 
angles in order to correctly fit the 
breadboard sockets.

Pin 13
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Open Up the Arduino IDE software on your computer. Coding in the Arduino 
language will control your circuit. Open the code for Circuit 1 by accessing the “SIK 
Guide Code” you downloaded and placed into your “Example” folder earlier.

Open Your First Sketch:

File Edit Sketch Tools Help

1.Basics
2.Digital
3.Analog
4.Communication
5.Control
6.Sensors
7.Displays
8.Strings
ArduinoISP
SIK Guide Code

EEPROM
Ethernet
Firmata
Liquid Crystal
SD
Servo
SoftwareSerial
SPI
Stepper
Wire

Page Setup
Print

New
Open...
Sketchbook
Examples
Close
Save
Save As...
Upload
Upload Using Progammer

Circuit #1
Circuit #2
Circuit #3
Circuit #4
Circuit #5
Circuit #6
Circuit #7
Circuit #8
Circuit #9
Circuit #10
Circuit #11
Circuit #12
Circuit #13
Circuit #14

Circuit #1

/*
  Blink

  Turns on an LED on for one second, 
  then off for one second, repeatedly.
 
  This example code is in the public domain.

 */

void setup() {                
  // initialize the digital pin as an output.
  // Pin 13 has an LED connected on most Arduino boards:
  pinMode(13, OUTPUT);     
}

void loop() {
  digitalWrite(13, HIGH);   // set the LED on
  delay(1000);              // wait for a second
  digitalWrite(13, LOW);    // set the LED off
  delay(1000);              // wait for a second
}

// Circuit #1



Verify

Upload

// The result of a completed circuit with correct code after verified and uploaded.

�is compiles your code. �e IDE changes it from text into instructions the computer 
can understand.

�is sends the instructions via the USB cable to the computer chip on the Arduino board. 
�e Arduino will then begin running your code automatically.



Circuit 2 Arduino Code:1

Troubleshooting:

LED Not Lighting Up?
LEDs will only work in one direction. Try taking it out and 
twisting it 180 degrees (no need to worry, installing it backwards does 
no permanent harm).

Program Not Uploading 
�is happens sometimes, the most likely cause is a confused 
serial port, you can change this in tools>serial port>

Still No Success?
A broken circuit is no fun, send us an e-mail and we will get 
back to you as soon as we can: techsupport@sparkfun.com

You should see your LED blink on and o�. If 
it isn't, make sure you have assembled the 
circuit correctly and veri�ed and uploaded the 
code to your board or see the troubleshooting 
tips below. 

Before you can use one of the Arduino's pins, you need to tell the 
Arduino whether it is an INPUT or OUTPUT. We use a built-in 
"function" called pinMode() to do this.

When you're using a pin as an OUTPUT, you can command it to be 
HIGH (output 5 Volts), or LOW (output 0 Volts).

digitalWrite(13, HIGH);

pinMode(13, OUTPUT);

Code to Note:

Real World Application:

Almost all modern �at screen televisions and monitors 
have LED indicator lights to show they are on or o�.

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 1

What you Should See:

This is where you will find the 
Arduino code for each circuit.

Remember to Verify and 
Upload your code.

See if your circuit is complete 
and working in this section.

Begin to understand how the 
Arduino code works. See below.

This is a section dedicated to the most 
common mistakes made while assembling 
the circuit. 

Here you will find examples of the circuit 
you just completed in the real world. 
Many of the theories in these circuits are 
used in things you use everyday!
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MP3 players’ volume control is an example of a 
potentiometer in action.

Circuit 2 Arduino Code:2

Troubleshooting:

Sporadically Working 
�is is most likely due to a slightly dodgy connection 
with the potentiometer's pins. �is can usually be 
conquered by holding the potentiometer down.

Not Working
Make sure you haven't accidentally connected the 
potentiometer's wiper to digital pin 2 rather than analog 
pin 2. (the row of pins beneath the power pins).

Still Backward
You can try operating the circuit upside down. 
Sometimes this helps.

You should see the LED blink faster 
or slower in accordance with your 
potentiometer.  If it isn't working, 
make sure you have assembled the 
circuit correctly and veri�ed and 
uploaded the code to your board or 
see the troubleshooting tips below. 

A "variable" is a number you've given a name to. You must 
introduce, or "declare" variables before you use them; here we're 
declaring a variable called sensorValue, of type "int" (integer). Don't 
forget that variable names are case-sensitive!

int sensorValue;

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 2

What you Should See:

The Arduino is very very fast, capable of running thousands of lines 
of code each second. To slow it down so that we can see what it's 
doing, we'll often insert delays into the code. Delay() counts in 
milliseconds; there are 1000 ms in one second.

delay(sensorValue);

We use the analogRead() function to read the value on an 

analog pin. analogRead() takes one parameter, the analog 

pin you want to use ("sensorPin"), and returns a number 

("sensorValue") between 0 (0 Volts) and 1023 (5 Volts).

sensorValue = analogRead(sensorPin);  
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Many electronics such as 
videogame consoles use RGB 
LEDs to have the versatility 
to show di�erent colors in 
the same area. Often times 
the di�ent colors represent 
di�erent states of working 
condition.

Circuit 2 Arduino Code:3

Troubleshooting:

LED Remains Dark or Shows Incorrect Color
With the four pins of the LED so close together, it’s 
sometimes easy to misplace one. Double check each 
pin is where it should be.

Seeing Red
�e red diode within the RGB LED may be a bit brighter 
than the other two. To make your colors more balanced, 
use a higher ohm resistor. Or adjust in code.

analogWrite(RED_PIN, redIntensity);
 
to 

analogWrite(RED_PIN, redIntensity/3);

You should see your LED turn on, 
but this time in new, crazy colors! If it 
isn't, make sure you have assembled 
the circuit correctly and veri�ed and 
uploaded the code to your board or 
see the troubleshooting tips below.

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 3

What you Should See:

A for() loop is used to step a number across a range, and 
repeatedly runs code within the brackets {}. Here the variable "x" 
starts a 0, ends at 767, and increases by one each time ("x++").

for (x = 0; x < 768; x++)
{}

The Arduino is very very fast, capable of running thousands of lines 
of code each second. To slow it down so that we can see what it's 
doing, we'll often insert delays into the code. Delay() counts in 
milliseconds; there are 1000 ms in one second.

delay(sensorValue);

"If / else" statements are used to make choices in your programs. The 

statement within the parenthesis () is evaluated; if it's true, the code within 

the first brackets {} will run. If it's not true, the code within the second 

brackets {} will run.

if (x <= 255)
{}
else
{}



So you have gotten one LED to blink on and o� –  
fantastic! Now it's time to up the stakes a little bit – by 
connecting EIGHT LEDS AT ONCE. We'll also give 
our Arduino a little test by creating various lighting 
sequences. �is circuit is a great setup to start practicing 
writing your own programs and getting a feel for the 
way Arduino works.

Along with controlling the LEDs, you’ll learn about a 
couple programming tricks that keep your code neat 
and tidy:

for() loops - used when you want to run a piece of 
code several times

arrays[ ] - used to make managing variables easier by 
grouping them together

Multiple LEDsPin 2 Pin 3 Pin 4 Pin 5

GND

LED
Light Emitting Diode

LED
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Circuit 2 Arduino Code:4

Troubleshooting:

Some LEDs Fail to Light 
It is easy to insert an LED backwards. Check the LEDs 
that aren't working and ensure they the right way 
around.

Operating out of sequence
With eight wires it's easy to cross a couple. Double check 
that the �rst LED is plugged into pin 2 and each pin 
there after.

Starting Afresh
Its easy to accidentally misplace a wire without noticing. 
Pulling everything out and starting with a fresh slate is 
often easier than trying to track down the problem.

�is is similar to circuit number one, but 
instead of one LED, you should see all the 
LEDs blink.  If they aren't, make sure you 
have assembled the circuit correctly and 
veri�ed and uploaded the code to your board 
or see the troubleshooting tips below. 

Code to Note:

Real World Application:

Scrolling marquee displays are generally used to spread 
short segments of important information. �ey are built 
out of many LEDs.

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 4

What you Should See:

When you have to manage a lot of variables, an 
"array" is a handy way to group them together. Here 
we're creating an array of integers, called ledPins, 
with eight elements.

int ledPins[] = {2,3,4,5,6,7,8,9};

Computers like to do the same things each time they run. But 
sometimes you want to do things randomly, such as simulating the 
roll of a dice. The random() function is a great way to do this. See 
http://arduino.cc/en/Reference/Random for more information.

index = random(8);

You refer to the elements in an array by their position. The first 

element is at position 0, the second is at position 1, etc. You refer to 

an element using "ledPins[x]" where x is the position. Here we're 

making digital pin 2 HIGH, since the array element at position 0 is "2".

digitalWrite(ledPins[0], HIGH);
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Circuit 2

Up until now, we’ve focused solely on outputs. Now 
we’re going to go to the other end of spectrum and 
play around with inputs. In this circuit, we’ll be 
looking at one of the most common and simple 
inputs – a push button. �e way a push button works 
with Arduino is that when the button is pushed, the 
voltage goes LOW. �e Arduino reads this and reacts 
accordingly. In this circuit, you will also use a pull-up 
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Push Buttons

PA
RT

S: Wire

7X

CIRCUIT #5 5
Pin 2

+5 Volts

resistor

Pin 3

LED

GND
(ground) (-)

resistor
(Orange-Orange-Brown)

(330ohm)

Push Button

2X

LED

1X

330Ω
Resistor

1X

10KΩ
Resistor

2X

Pin 13

Pin 2 Pin 3

p.10p.36



Ci
rc

ui
t 5

: P
us

h 
Bu

tto
ns

a
b

c
d

e
f

g
h

i
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30

a
b

c
d

e
f

g
h

i

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30



Co
m

po
ne

nt
:

Im
ag

e 
Re

fe
re

nc
e:

LE
D 

(5
m

m
)

+
-

+
-

h2
0

h2
1

Pu
sh

 B
ut

to
n

d4
g4

d6
g6

Pu
sh

 B
ut

to
n

d9
g9

d1
1

g1
1

Ju
m

pe
r W

ire
Pi

n 
2

h6

Ju
m

pe
r W

ire
Pi

n 
3

h1
1

Ju
m

pe
r W

ire
Pi

n 
13

j2
0

i4
Ju

m
pe

r W
ire

i9
Ju

m
pe

r W
ire

10
KΩ

 R
es

is
to

r
a1

5
i6

+

10
KΩ

 R
es

is
to

r
i1

1
+

33
0Ω

 R
es

is
to

r
j2

1
+

O
ne

 o
f t

he
 th

in
gs

 th
at

 m
ak

es
 th

e A
rd

ui
no

 so
 u

se
fu

l i
s t

ha
t i

t c
an

 m
ak

e c
om

pl
ex

 d
ec

isi
on

s 
ba

se
d 

on
 th

e i
np

ut
 it

's 
ge

tti
ng

. F
or

 ex
am

pl
e, 

yo
u 

co
ul

d 
m

ak
e a

 th
er

m
os

ta
t t

ha
t t

ur
ns

 o
n 

a 
he

at
er

 if
 it

 g
et

s t
oo

 co
ld

, a
 fa

n 
if 

it 
ge

ts 
to

o 
ho

t, 
w

at
er

s y
ou

r p
lan

ts 
if 

th
ey

 g
et

 to
o 

dr
y,

 et
c.

In
 o

rd
er

 to
 m

ak
e s

uc
h 

de
cis

io
ns

, t
he

 A
rd

ui
no

 p
ro

vi
de

s a
 se

t o
f l

og
ic 

op
er

at
io

ns
 th

at
 le

t y
ou

 
bu

ild
 co

m
pl

ex
 "i

f"
 st

at
em

en
ts.

 �
ey

 in
clu

de
:

Yo
u 

ca
n 

co
m

bi
ne

 th
es

e f
un

ct
io

ns
 to

 b
ui

ld
 co

m
pl

ex
 if

() 
sta

te
m

en
ts.

 

Fo
r e

xa
m

pl
e:

if 
((

m
od

e 
==

 h
ea

t)
 &

&
 ((

te
m

pe
ra

tu
re

 <
 th

re
sh

ol
d)

 ||
 (o

ve
rr

id
e 

==
 tr

ue
))

)
{ di

gi
ta

lW
ri

te
(H

EA
T

ER
, H

IG
H

);
} ...

w
ill

 tu
rn

 o
n 

a h
ea

te
r i

f y
ou

're
 in

 h
ea

tin
g 

m
od

e A
N

D
 th

e t
em

pe
ra

tu
re

 is
 lo

w
, O

R
 if

 y
ou

 
tu

rn
 o

n 
a m

an
ua

l o
ve

rr
id

e. 
U

sin
g 

th
es

e l
og

ic 
op

er
at

or
s, 

yo
u 

ca
n 

pr
og

ra
m

 y
ou

r A
rd

ui
no

 to
 

m
ak

e i
nt

ell
ig

en
t d

ec
isi

on
s a

nd
 ta

ke
 co

nt
ro

l o
f t

he
 w

or
ld

 ar
ou

nd
 it

!

Ho
w

 to
 u

se
 lo

gi
c 

lik
e 

a 
Vu

lc
an

:

=
=

EQ
UI

VA
LE

NC
E

A 
==

 B
 is

 tr
ue

 if
 A

 a
nd

 B
 a

re
 th

e 
SA

M
E.

!=
DI

FF
ER

EN
CE

A 
!=

 B
 is

 tr
ue

 if
 A

 a
nd

 B
 a

re
 N

OT
 T

HE
 S

AM
E.

&
&

AN
D

A 
&

&
 B

 is
 tr

ue
 if

 B
OT

H 
A 

an
d 

B 
ar

e 
TR

UE
.

||
OR

A 
|| 

B 
is

 tr
ue

 if
 A

 o
r B

 o
r B

OT
H 

ar
e 

TR
UE

.

!
NO

T
!A

 is
 T

RU
E 

if 
A 

is
 F

AL
SE

, a
nd

 F
AL

SE
 if

 A
 is

 T
RU

E.



�e buttons we used here are similar to the buttons in 
most videogame controllers.

Circuit 2 Arduino Code:5

Troubleshooting:

Light Not Turning On 
�e pushbutton is square, and because of this it is easy to 
put it in the wrong way. Give it a 90 degree twist and see 
if it starts working.

Light Not Fading 
A bit of a silly mistake we constantly made, when you 
switch from simple on o� to fading, remember to move 
the LED wire from pin 13 to pin 9.

Underwhelmed 
No worries, these circuits are all super stripped down to 
make playing with the components easy, but once you 
throw them together the sky is the limit.

You should see the LED turn on 
and o� as you press the button. If 
it isn't working, make sure you 
have assembled the circuit correctly 
and veri�ed and uploaded the code 
to your board or see the 
troubleshooting tips below. 

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 5

What You Should See:

The digital pins can be used as inputs as well as 
outputs. Before you do either, you need to tell the 
Arduino which direction you're going.

pinMode(button2Pin, INPUT);

Because we've connected the button to GND, it will read LOW 
when it's being pressed. Here we're using the "equivalence" 
operator ("==") to see if the button is being pressed.

if (button1State == LOW)

To read a digital input, you use the digitalRead() 
function. It will return HIGH if there's 5V present at 
the pin, or LOW if there's 0V present at the pin.

button1State = digitalRead(button1Pin);



Circuit 2

So you’ve already played with a potentiometer, which 
varies resistance based on the twisting of a knob. In 
this circuit, you’ll be using a photo resistor, which 
changes resistance based on how much light the 
sensor receives. Since the Arduino can’t directly 
interpret resistance (rather it reads voltage), we use a 
voltage divider to use our photo resistor. �is voltage 
divider will output a high voltage when it is getting a 
lot of light and a low voltage when it is not.

Photo Resistor

PA
RT

S: Wire

6X

CIRCUIT #6 6

LED

1X

330Ω
Resistor

1X

Photo Resistor

1X

LED

GND
(ground) (-)

photo
resistor

+5 Volts

resistor
(Orange-Orange-Brown)

(330ohm)

resistor
(Brown-Black-Orange)

(10k ohm)

10KΩ
Resistor

1X

Pin 9

Pin AØ

p.40
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A street lamp uses a light sensor to detect when to turn 
the lights on at night.

Circuit 2 Arduino Code:6

Troubleshooting:

LED Remains Dark
�is is a mistake we continue to make time and time 
again, if only they could make an LED that worked both 
ways. Pull it up and give it a twist.

It Isn't Responding to Changes in Light
Given that the spacing of the wires on the photo-resistor 
is not standard, it is easy to misplace it. Double check it’s 
in the right place.

Still Not Quite Working
You may be in a room which is either too bright or dark. 
Try turning the lights on or o� to see if this helps. Or if 
you have a �ashlight near by give that a try.

You should see the LED grow brighter 
or dimmer in accordance with how 
much light your photoresistor is 
reading.  If it isn't working, make sure 
you have assembled the circuit 
correctly and veri�ed and uploaded 
the code to your board or see the 
troubleshooting tips below. 

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 6

What You Should See:

When we read an analog signal using analogRead(), it will 

be a number from 0 to 1023. But when we want to drive a 

PWM pin using analogWrite(), it wants a number from 0 to 

255. We can "squeeze" the larger range into the smaller 

range using the map() function.

lightLevel = map(lightLevel, 0, 1023, 0, 255);

Because map() could still return numbers outside the "to" 

range, we'll also use a function called constrain() that will 

"clip" numbers into a range. If the number is outside the 

range, it will make it the largest or smallest number. If it is 

within the range, it will stay the same.

lightLevel = constrain(lightLevel, 0, 255);



Circuit 2

A temperature sensor is exactly what it sounds like – a 
sensor used to measure ambient temperature. �is 
particular sensor has three pins – a positive, a ground, 
and a signal. For every centigrade degree it reads, it 
outputs 10 millivolts. In this circuit, you’ll learn how to 
integrate the temperature sensor with your Arduino, 
and use the Arduino IDE’s debug window to display 
the temperature.

Temperature Sensor

CIRCUIT #7 7

p.44

Pin AØ

TMP36
(precision

temperature
sensor)

GND
(ground) (-)

5 Volts

+5v
signal
gnd

PA
RT

S: Wire

5X

Temp. Sensor

1

When you’re building the circuit be careful 
not to mix up the temperature sensor and the 
transistor, they’re almost identical.

X

FRONT

BACK
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Building climate control systems use a temperature sensor 
to monitor and maintain their settings.

Circuit 2 Arduino Code:7

Troubleshooting:

Nothing Seems to Happen
�is program has no outward indication it is working. To 
see the results you must open the Arduino IDE's serial 
monitor (instructions on previous page).

Gibberish is Displayed
�is happens because the serial monitor is receiving data at 
a di�erent speed than expected. To �x this, click the 
pull-down box that reads "*** baud" and change it to 
"9600 baud".

Temperature Value is Unchanging 
Try pinching the sensor with your �ngers to heat it up or 
pressing a bag of ice against it to cool it down.

You should see be able to read the 
temperature your temperature 
sensor is detecting on the serial 
monitor in the Arduino IDE. If it 
isn't working, make sure you have 
assembled the circuit correctly and 
veri�ed and uploaded the code to 
your board or see the troubleshoot-
ing tips below. 

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 7

What You Should See:

voltage: 0.73  deg C: 22.75  deg F: 72.96

voltage: 0.73  deg C: 22.75  deg F: 72.96

voltage: 0.73  deg C: 22.75  deg F: 72.96

voltage: 0.73  deg C: 22.75  deg F: 72.96

voltage: 0.73  deg C: 22.75  deg F: 72.96

Before using the serial monitor, you must call Serial.begin() to 
initialize it. 9600 is the "baud rate", or communications speed. 
When two devices are communicating with each other, both 
must be set to the same speed.

Serial.begin(9600);

Serial.print() will print everything on the same line. Serial.println() 
will move to the next line. By using both of these commands 
together, you can create easy-to-read printouts of text and data. 

Serial.println(degreesF);

The Serial.print() command is very smart. It can print out almost 
anything you can throw at it, including variables of all types, 
quoted text (AKA "strings"), etc. 

See http://arduino.cc/en/Serial/Print for more info.

Serial.print(degreesC);



Circuit 2

Servos are ideal for embedded electronics applications 
because they do one thing very well that spinning motors 
cannot – they can move to a position accurately. By 
varying the pulse of voltage a servo receives, you can 
move a servo to a speci�c position. For example, a pulse 
of 1.5 milliseconds will move the servo 90 degrees. In this 
circuit, you’ll learn how to use PWM (pulse width 
modulation) to control and rotate a servo.

A Single Servo

PA
RT

S: Wire

8X

CIRCUIT #8 8

p.48

Servo

1X

Mini Servo

+5 volts
(5V)

GND
(ground) (-)

gnd
(black)

signal
(white)

+5v
(red)

Pin 9
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Circuit 2 Arduino Code:8

Troubleshooting:

Servo Not Twisting 
Even with colored wires it is still shockingly easy to plug a 
servo in backward. �is might be the case.

Still Not Working
A mistake we made a time or two was simply forgetting 
to connect the power (red and brown wires) to +5 volts 
and ground.

Fits and Starts
If the servo begins moving then twitches, and there's a 
�ashing light on your Arduino board, the power supply 
you are using is not quite up to the challenge. Using a 
wall adapter instead of USB should solve this problem.

You should see your servo motor move to 
various locations at several speeds. If the 
motor doesn't move, check your 
connections and make sure you have 
veri�ed and uploaded the code, or see the 
troubleshooting tips below. 

Code to Note:

Real World Application:

Robotic arms you might see in an assembly line or sci-� 
movie probably have servos in them.

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 8

What You Should See:

#include is a special "preprocessor" command that inserts a library 
(or any other file) into your sketch. You can type this command 
yourself, or choose an installed library from the "sketch / import 
library" menu.

#include <Servo.h>

Servos don't spin all the way around, but they can be commanded to move to 

a specific position. We use the servo library's write() command to move a 

servo to a specified number of degrees(0 to 180). Remember that the servo 

requires time to move, so give it a short delay() if necessary.

servo1.write(180);

The servo library adds new commands that let you control a servo. 
To prepare the Arduino to control a servo, you must first create a 
Servo "object" for each servo (here we've named it "servo1"), and 
then "attach" it to a digital pin (here we're using pin 9).

Servo servo1;

servo1.attach(9);
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In this circuit, we will use a �ex sensor to measure, 
well, �ex! A �ex sensor uses carbon on a strip of 
plastic to act like a variable resistor, but instead of 
changing the resistance by turning a knob, you 
change it by �exing (bending) the component. We 
use a "voltage divider" again to detect this change in 
resistance. �e sensor bends in one direction and the 
more it bends, the higher the resistance gets; it has a 
range from about 10K ohm to 35K ohm. In this 
circuit we will use the amount of bend of the �ex 
sensor to control the position of a servo.

Flex Sensor

PA
RT

S:
CIRCUIT #9 9

Potentiometer

1X

Servo

1X

Flex Sensor

1X

10KΩ
Resistor

1X

Wire

11X

+5 volts
(5V)

+5 volts
(5V)

GND
(ground) (-)

Mini Servo

resistor

flex
sensor

(10K ohm)
(Brown-Black-Orange)

p.10p.52

Pin AØ

Pin 9



a
b

c
d

e
f

g
h

i
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30

a
b

c
d

e
f

g
h

i

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30

Ci
rc

ui
t 9

: F
le

x 
Se

ns
or



It 
ha

pp
en

s t
o 

ev
er

yo
ne

 - 
yo

u 
w

rit
e a

 sk
et

ch
 w

hi
ch

 su
cc

es
sfu

lly
 co

m
pi

les
 an

d 
up

lo
ad

s, 
bu

t y
ou

 ca
n'

t �
gu

re
 o

ut
 w

hy
 it

's 
no

t d
oi

ng
 w

ha
t y

ou
 w

an
t i

t t
o.

 L
ar

ge
r c

om
pu

te
rs 

ha
ve

 sc
re

en
s, 

ke
yb

oa
rd

s, 
an

d 
m

ice
 th

at
 y

ou
 ca

n 
us

e t
o 

de
bu

g 
yo

ur
 co

de
, b

ut
 ti

ny
 

co
m

pu
te

rs 
lik

e t
he

 A
rd

ui
no

 h
av

e n
o 

su
ch

 th
in

gs
.

�
e k

ey
 to

 v
isi

bi
lit

y 
in

to
 a 

m
icr

oc
on

tro
lle

r i
s o

ut
pu

t. 
�

is 
ca

n 
be

 al
m

os
t a

ny
th

in
g,

 
in

clu
di

ng
 L

ED
s a

nd
 b

uz
ze

rs,
 b

ut
 o

ne
 o

f t
he

 m
os

t u
se

fu
l t

oo
ls 

is 
th

e s
er

ia
l m

on
ito

r. 
U

sin
g 

Se
ri

al
.p

ri
nt

()
 an

d 
pr

in
tln

()
, y

ou
 ca

n 
ea

sil
y 

ou
tp

ut
 h

um
an

-re
ad

ab
le 

te
xt

 an
d 

da
ta

 fr
om

 th
e A

rd
ui

no
 to

 a 
w

in
do

w
 b

ac
k 

on
 th

e h
os

t c
om

pu
te

r. 
�

is 
is 

gr
ea

t f
or

 y
ou

r 
sk

et
ch

's 
�n

al 
ou

tp
ut

, b
ut

 it
's 

als
o 

in
cr

ed
ib

ly
 u

se
fu

l f
or

 d
eb

ug
gi

ng
.

De
bu

gg
in

g 
yo

ur
 s

ke
tc

he
s 

us
in

g 
th

e 
Se

ria
l M

on
ito

r:
Co

m
po

ne
nt

:
Im

ag
e 

Re
fe

re
nc

e:

i2
0

i2
4

Se
rv

o
e1

e3
e2

e1
Ju

m
pe

r W
ire

i1
9

Ju
m

pe
r W

ire

h2
4

+
Ju

m
pe

r W
ire

h2
4

+
Ju

m
pe

r W
ire

h2
4

+
Ju

m
pe

r W
ire

Ju
m

pe
r W

ire

Ju
m

pe
r W

ire

Ju
m

pe
r W

ire

Ju
m

pe
r W

ire

e2
Ju

m
pe

r W
ire

e3
Ju

m
pe

r W
ire

Fl
ex

 S
en

so
r

h1
9

h2
0

10
KΩ

 R
es

is
to

r

j2
0

A0

b1
+

a2
+

a3
Pi

n 
9

5V5V
+

G
N

D

An
d 

if 
yo

u 
ru

n 
th

e c
od

e a
ga

in
, y

ou
'll

 se
e t

he
 

ou
tp

ut
 y

ou
 w

an
te

d:
fo

r 
(x

 =
 1

 ; 
 x

 <
 9

 ; 
x+

+)
{    

   
Se

ri
al

.p
ri

nt
(x

);
}

12
34

56
78

Yo
u 

wa
nt

ed
 1

 to
 8

, b
ut

 th
e l

oo
p 

is 
ac

tu
all

y g
ivi

ng
 yo

u 
0 

to
 7

. W
ho

op
s! 

N
ow

 yo
u 

ju
st 

ne
ed

 to
 �

x t
he

 lo
op

.

01
23

45
67

Le
t's

 sa
y 

yo
u 

w
an

te
d 

a f
or

()
 lo

op
 fr

om
 1

 to
 8

, 
bu

t y
ou

r c
od

e j
us

t d
oe

sn
't 

se
em

 to
 b

e w
or

ki
ng

 
rig

ht
. J

us
t a

dd
 S

er
ia

l.b
eg

in
(9

60
0)

; t
o 

yo
ur

 
se

tu
p(

) f
un

ct
io

n,
 an

d 
ad

d 
a S

er
ia

l.p
ri

nt
()

 o
r 

pr
in

tln
()

 to
 y

ou
r l

oo
p:

fo
r 

(x
 =

 0
; x

 <
 8

; x
++

)
{    

   
Se

ri
al

.p
ri

nt
(x

);
}



Controller accessories for videogame consoles like 
Nintendo’s “Power Glove” use �ex-sensing technology. It 
was the �rst video game controller attempting to mimic 
hand movement on a screen in real time.

Circuit 2 Arduino Code:9

Troubleshooting:

Servo Not Twisting
Even with colored wires it is still shockingly easy to plug a 
servo in backwards. �is might be the case.

Servo Not Moving as Expected
�e sensor is only designed to work in one direction. Try 
�exing it the other way (where the striped side faces 
out on a convex curve).

Servo Doesn’t Move very Far
You need to modify the range of values in the call to the 
map() function.

You should see the servo motor move 
in accordance with how much you 
are �exing the �ex sensor. If it isn't 
working, make sure you have 
assembled the circuit correctly and 
veri�ed and uploaded the code to 
your board or see the troubleshooting 
tips below. 

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 9

What You Should See:

Because the flex sensor / resistor combination won't 
give us a full zero to five-volt range, we're using the 
map() function as a handy way to reduce that range. 
Here we've told it to only expect values from 600 to 
900, rather than 0 to 1023.

servoposition = map(flexposition, 600, 900, 0, 180);

Because map() could still return numbers outside the "to" 

range, we'll also use a function called constrain() that will 

"clip" numbers into a range. If the number is outside the 

range, it will make it the largest or smallest number. If it is 

within the range, it will stay the same.

Serial.print("sensor: ");

Serial.print(flexposition);

Serial.print("  servo: ");

Serial.println(servoposition);
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Circuit 2

In this circuit, we are going to use yet another kind of 
variable resistor – this time, a soft potentiometer (or 
soft pot). �is is a thin and �exible strip that can 
detect where pressure is being applied. By pressing 
down on various parts of the strip, you can vary the 
resistance from 100 to 10K ohms. You can use this 
ability to track movement on the soft pot, or simply 
as a button. In this circuit, we’ll get the soft pot up 
and running to control an RGB LED.
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�e knobs found on many objects, like a radio for 
instance, are using similar concepts to the one you just 
completed for this circuit.

Circuit 2 Arduino Code:10

Troubleshooting:

LED Remains Dark or Shows Incorrect Color
With the four pins of the LED so close together, it’s 
sometimes easy to misplace one. Try double checking each 
pin is where it should be.

Bizarre Results
�e most likely cause of this is if you’re pressing the 
potentiometer in more than one position. �is is normal 
and can actually be used to create some neat results. 

You should see the RGB LED change 
colors in accordance with how you 
interact with the soft potentiometer. 
If it isn't working, make sure you 
have assembled the circuit correctly 
and veri�ed and uploaded the code to 
your board, or see the troubleshoot-
ing tips below. 

These big, scary functions take a 

single Value (RGBposition) and 

calculate the three RGB values 

necessary to create a rainbow of 

color. The functions create three 

"peaks" for the red, green, and blue 

values, which overlap to mix and 

create new colors. Even if you're 

not 100% clear how it works, you 

can copy and paste this (or any) 

function into your own code and 

use it yourself.

redValue = constrain(map(RGBposition, 0, 341, 255, 0), 0, 255)

 + constrain(map(RGBposition, 682, 1023, 0, 255), 0, 255);

   

greenValue = constrain(map(RGBposition, 0, 341, 0, 255), 0, 255)

 - constrain(map(RGBposition, 341, 682, 0,255), 0, 255);

blueValue = constrain(map(RGBposition, 341, 682, 0, 255), 0, 255)

- constrain(map(RGBposition, 682, 1023, 0, 255), 0, 255);

     

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 10

What You Should See:



Circuit 2

In this circuit, we'll again bridge the gap between the 
digital world and the analog world. We'll be using a 
buzzer that makes a small "click" when you apply 
voltage to it (try it!). By itself that isn't terribly 
exciting, but if you turn the voltage on and o� 
hundreds of times a second, the buzzer will produce a 
tone. And if you string a bunch of tones together, 
you've got music! �is circuit and sketch will play a 
classic tune. We'll never let you down!

Buzzer
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If the buzzer doesn't easily fit 
into the holes on the breadboard, 
try rotating it slightly.



Ci
rc

ui
t 1

1:
 P

ie
zo

 E
le

m
en

ts

a
b

c
d

e
f

g
h

i
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30

a
b

c
d

e
f

g
h

i

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30



Co
m

po
ne

nt
:

Im
ag

e 
Re

fe
re

nc
e:

Pi
ez

o 
El

em
en

t
+

-
j9

j7

Ju
m

pe
r W

ire
Pi

n 
9

j9

i7

Ju
m

pe
r W

ire
G

N
D

Ju
m

pe
r W

ire

Ju
m

pe
r W

ire
5V5V

+

Ar
du

in
o 

co
nt

ai
ns

 a 
w

ea
lth

 o
f b

ui
lt-

in
 fu

nc
tio

ns
 th

at
 ar

e u
se

fu
l f

or
 al

l k
in

ds
 o

f t
hi

ng
s. 

(S
ee

 h
tt

p:
//

ar
du

in
o.

cc
/e

n/
R

ef
er

en
ce

 fo
r a

 li
st)

. B
ut

 y
ou

 ca
n 

als
o 

ea
sil

y 
cr

ea
te

 y
ou

r 
ow

n 
fu

nc
tio

ns
. H

er
e's

 a 
sim

pl
e e

xa
m

pl
e n

am
ed

 "a
dd

", 
w

hi
ch

 ad
ds

 tw
o 

nu
m

be
rs 

to
ge

th
er

 an
d 

re
tu

rn
s t

he
 re

su
lt.

 L
et

's 
br

ea
k 

it 
do

w
n.

Yo
ur

 fu
nc

tio
ns

 ca
n 

ta
ke

 in
 v

alu
es

 ("
pa

ra
m

et
er

s"
), 

an
d 

re
tu

rn
 a 

va
lu

e, 
as

 th
is 

on
e d

oe
s. 

Bu
t y

ou
 ca

n 
als

o 
do

 ei
th

er
 o

r n
on

e o
f t

ho
se

 th
in

gs
, i

f y
ou

 w
ish

.

If 
yo

u'
ll 

be
 p

as
sin

g 
pa

ra
m

et
er

s /
to

/ y
ou

r f
un

ct
io

n,
 p

ut
 th

em
 (a

nd
 th

eir
 ty

pe
s) 

in
 th

e 
pa

re
nt

he
se

s a
fte

r t
he

 fu
nc

tio
n 

na
m

e. 
If 

yo
u 

w
on

't 
be

 g
iv

in
g 

yo
ur

 fu
nc

tio
n 

an
y 

pa
ra

m
et

er
s, 

ju
st 

us
e a

n 
em

pt
y 

pa
re

nt
he

sis
 ()

 af
te

r t
he

 n
am

e.

If 
yo

u'
ll 

be
 re

tu
rn

in
g 

a v
alu

e /
fr

om
/ y

ou
r f

un
ct

io
n,

 p
ut

 th
e t

yp
e o

f t
he

 re
tu

rn
 v

alu
e i

n 
fro

nt
 o

f t
he

 fu
nc

tio
n 

na
m

e. 
�

en
 in

 y
ou

r f
un

ct
io

n,
 w

he
n 

yo
u'

re
 re

ad
y 

to
 re

tu
rn

 th
e 

va
lu

e, 
pu

t i
n 

a r
et

ur
n(

) s
ta

te
m

en
t. 

If 
yo

u 
w

on
't 

be
 re

tu
rn

in
g 

a v
alu

e, 
pu

t "
vo

id
" i

n 
fro

nt
 o

f t
he

 fu
nc

tio
n 

na
m

e (
ju

st 
lik

e y
ou

'v
e a

lre
ad

y 
se

en
 fo

r t
he

 se
tu

p(
) a

nd
 lo

op
()

 
fu

nc
tio

ns
).

W
he

n 
yo

u 
w

rit
e y

ou
r o

w
n 

fu
nc

tio
ns

, y
ou

 m
ak

e y
ou

r c
od

e n
ea

te
r a

nd
 ea

sie
r t

o 
re

-u
se

. 

Cr
ea

tin
g 

yo
ur

 o
w

n 
fu

nc
tio

ns
:

in
t a

dd
(i

nt
 p

ar
am

et
er

1,
 in

t p
ar

am
et

er
2)

{  
in

t x
;

 
x 

= 
pa

ra
m

et
er

1 
+ 

pa
ra

m
et

er
2;

 
re

tu
rn

(x
);

}



Many modern megaphones have settings that use a loud 
ampli�ed buzzer. �ey are usually very loud and quite 
good at getting people’s attention.

Circuit 2 Arduino Code:11

Troubleshooting:

No Sound
Given the size and shape of the piezo element it is easy to 
miss the right holes on the breadboard. Try double 
checking its placement.

Can't �ink While the Melody is Playing
Just pull up the piezo element whilst you think, upload 
your program then plug it back in.

Tired of Twinkle Twinkle Little Star
�e code is written so you can easily add your own songs.

You should see - well, nothing! 
But you should be able to hear 
you piezo element playing 
"Twinkle, Twinkle Little Star" (or 
possibly, "�e ABCs"). If it isn't 
working, make sure you have 
assembled the circuit correctly and 
veri�ed and uploaded the code to 
your board or see the 
troubleshooting tips below. 

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 11

What You Should See:

Up until now we've been working solely with numerical 

data, but the Arduino can also work with text. Characters 

(single, printable, letters, numbers and other symbols) have 

their own type, called "char". When you have an array of 

characters, it can be defined between double-quotes (also 

called a "string"), OR as a list of single-quoted characters. 

char notes[] = "cdfda ag cdfdg gf ";

char names[] = {'c','d','e','f','g','a','b','C'};

One of Arduino's many useful built-in commands is the 

tone() function. This function drives an output pin at a 

certain frequency, making it perfect for driving buzzers and 

speakers. If you give it a duration (in milliseconds), it will 

play the tone then stop. If you don't give it a duration, it 

will keep playing the tone forever (but you can stop it with 

another function, noTone() ).

tone(pin, frequency, duration);



Circuit 2

Remember before when you played around with a servo 
motor? Now we are going to tackle spinning a motor. 
�is requires the use of a transistor, which can switch a 
larger amount of current than the Arduino can. When 
using a transistor, you just need to make sure its 
maximum specs are high enough for your use. �e 
transistor we are using for this circuit is rated at 40V max 
and 200 milliamps max – perfect for our toy motor! 

Spinning a Motor
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CIRCUIT #12 12
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When you’re building the circuit be careful 
not to mix up the transistor and the 
temperature sensor, they’re almost identical.
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Circuit 2 Arduino Code:12

Troubleshooting:

Motor Not Spinning
If you sourced your own transistor, double check with 
the data sheet that the pinout is compatible with a 
P2N2222AG (many are reversed).

Still No Luck
If you sourced your own motor, double check that it will 
work with 5 volts and that it does not draw too much 
power.

Still Not Working
Sometimes the Arduino board will disconnect from the 
computer. Try un-plugging and then re-plugging it into 
your USB port.

�e DC Motor should spin if you have 
assembled the circuit’s components correctly, 
and also veri�ed/uploaded the correct code. If 
your circuit is not working check the 
troubleshooting section below.

Code to Note:

Real World Application:

Radio Controlled(RC) cars use Direct Current(DC) 
motors to turn the wheels for propulsion.

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 12

What You Should See:

The Arduino's serial port can be used to receive as well as 

send data. Because data could arrive at any time, the Arduino 

stores, or "buffers" data coming into the port until you're 

ready to use it. The Serial.available() command returns the 

number of characters that the port has received, but haven't 

been used by your sketch yet. Zero means no data has arrived.

while (Serial.available() > 0)

If the port has data waiting for you, there are a number of 

ways for you to use it. Since we're typing numbers into the 

port, we can use the handy Serial.parseInt() command to 

extract, or "parse" integer numbers from the characters it's 

received. If you type "1" "0" "0" to the port, this function 

will return the number 100.

speed = Serial.parseInt();
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LED
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Circuit 2

In this circuit, we are going to use some of the lessons we 
learned in circuit 12 to control a relay. A relay is basically 
an electrically controlled mechanical switch. Inside that 
harmless looking plastic box is an electromagnet that, 
when it gets a jolt of energy, causes a switch to trip. In 
this circuit, you’ll learn how to control a relay like a pro 
– giving your Arduino even more powerful abilities! 

Relays
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Garage door openers use relays to operate. You might be 
able to hear the clicking if you listen closely.

Circuit 2 Arduino Code:13

Troubleshooting:

LEDs Not Lighting
Double-check that you've plugged them in correctly. �e 
longer lead (and non-�at edge of the plastic �ange) is the 
positive lead.

No Clicking Sound
�e transistor or coil portion of the circuit isn't quite 
working. Check the transistor is plugged in the right way.

Not Quite Working
�e included relays are designed to be soldered rather than 
used in a breadboard. As such you may need to press it in 
to ensure it works (and it may pop out occasionally).

You should be able to hear the 
relay contacts click, and see the 
two LEDs alternate illuminating 
at 1-second intervals. If you 
don't, double-check that you 
have assembled the circuit 
correctly, and uploaded the 
correct sketch to the board. Also, 
see the troubleshooting tips below. 

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 13

What You Should See:

When we turn on the transistor, which in turn energizes 

the relay's coil, the relay's switch contacts are closed. This 

connects the relay's COM pin to the NO (Normally Open) 

pin. Whatever you've connected using these pins will turn 

on. (Here we're using LEDs, but this could be almost anything.)

digitalWrite(relayPin, HIGH);

The relay has an additional contact called NC (Normally 

Closed). The NC pin is connected to the COM pin when 

the relay is OFF. You can use either pin depending on 

whether something should be normally on or normally off. 

You can also use both pins to alternate power to two 

devices, much like railroad crossing warning lights.

digitalWrite(relayPin, LOW);



Circuit 2

Shift Register
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Now we are going to step into the world of ICs (integrated 
circuits). In this circuit, you’ll learn all about using a shift 
register (also called a serial-to-parallel controller). �e shift 
register will give your Arduino an additional eight outputs, 
using only three pins on your board. For this circuit, you’ll 
practice by using the shift register to control eight LEDs. 
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Similar to circuit #4, a scrolling marquee display delivers 
a mesage with multiple LEDs. Essentially the same task 
the shift register achieves here in Circuit #14.

Circuit 2 Arduino Code:14

Troubleshooting:

�e Arduino's power LED goes out 
�is happened to us a couple of times, it happens when 
the chip is inserted backward. If you �x it quickly 
nothing will break.

Not Quite Working
Sorry to sound like a broken record but it is probably 
something as simple as a crossed wire.

Frustration
Shoot us an e-mail, this circuit is both simple and 
complex at the same time. We want to hear about 
problems you have so we can address them in future 
editions: techsupport@sparkfun.com

You should see the LEDs light up 
similarly to in circuit 4 (but this 
time, you're using a shift register). 
If they aren't, make sure you have 
assembled the circuit correctly 
and veri�ed and uploaded the 
code to your board, or see the 
troubleshooting tips below. 

Code to Note:

Real World Application:

Open Arduino IDE // File > Examples > SIK Guide > Circuit # 14

What You Should See:

You'll communicate with the shift register (and a lot of other parts) 

using an interface called SPI, or Serial Peripheral Interface. This 

interface uses a data line and a separate clock line that work together 

to move data in or out of the Arduino at high speed. The MSBFIRST 

parameter specifies the order in which to send the individual bits, in 

this case we're sending the Most Significant Bit first.

shiftOut(datapin, clockpin, MSBFIRST, data);

Bits are the smallest possible piece of memory in a computer; each 

one can store either a "1" or a "0". Larger numbers are stored as arrays 

of bits. Sometimes we want to manipulate these bits directly, for 

example now when we're sending eight bits to the shift register and 

we want to make them 1 or 0 to turn the LEDs on or off. The Arduino 

has several commands, such as bitWrite(), that make this easy to do.

bitWrite(data,desiredPin,desiredState);



This is just the beginning of your exploration into 
embedded electronics and coding. Our website has a 
wealth of tutorials to whet your appetite for more 
knowledge. We also host a community of hackers, 
engineers, DIYers, etc. in our forums. So log on to our 
website for more information about Arduino, or to plan 
ahead for your next project!

sparkfun.com

Visit us Online:
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